#1 June 27, 2013 02:21:59

Support
Registered:
Posts: 0
Profile   Send e-mail  

SPPDemo on Tiwi-uB2 EM with TI MSP-EXP430F5438

Hello,

We just got the TiWi-uB2 EM module. I 'm new in using your Bluetooth module. When I plug the TiWi-uB2 EM onto MSP-EXP430F5438, and them download the SPPDemo to the Flahser of F5438 following the insructions of the links below:

http://processors.wiki.ti.com/index.p...

But after flash and power on the modules again. I got the failure message on Tera Term, which shows:

OpenStack().

Stack Init Failed: -4

Unable to open the stack.

I 've tried many time and also checked the connectors switch on both EMs. I also switched the SLOW_32K crystal to internal.

when I got the above message, the red and yellow LEDs(LED1 and LED2) on MSP-EXP430F5438 are flicker alternately quickly. And there are only 2 leds(green LED1 and yellow LED2) on in TiWI-uB2 EM, the blue LED3 is on when power on and then change to off after a few seconds.

Do you think that it is the hardware issue or demo sofware problem? Thanks.

Regards,

Evan

Edited (June 27, 2013 02:21:59)

Offline

#2 June 27, 2013 07:48:12

pscharpf
Registered: 2015-06-29
Posts: 26
Profile   Send e-mail  

SPPDemo on Tiwi-uB2 EM with TI MSP-EXP430F5438

Hello Evan,

I believe the solution to your problem may be found in this post: http://www.lsr.com/ProductsForum/tabi...

Be sure the jumpers are correct on the expirementer board to select the correct BT_Stack_Lib (libTI_init_script_BT_CC256x.r43) in IAR when re-compiling code.

Edited (June 27, 2013 07:48:12)

Offline

#3 June 29, 2013 02:11:42

Support
Registered:
Posts: 0
Profile   Send e-mail  

SPPDemo on Tiwi-uB2 EM with TI MSP-EXP430F5438

Hello, thanks for you reply. I read the post discussion on it. But now my question is how to select the correct BT_Stack_Lib (libTI_init_script_BT_CC256x.r43) when we compile the code in IAR? I don 't find any file about libTI_init_script_BT_CC256x.r43. Thanks.

Evan

Edited (June 29, 2013 02:11:42)

Offline

#4 June 29, 2013 02:32:38

Support
Registered:
Posts: 0
Profile   Send e-mail  

SPPDemo on Tiwi-uB2 EM with TI MSP-EXP430F5438

And where is the file: BT_Stack_Lib (libTI_init_script_BT_CC256x.r43)? Thanks.

Edited (June 29, 2013 02:32:38)

Offline

#5 July 1, 2013 17:53:33

pscharpf
Registered: 2015-06-29
Posts: 26
Profile   Send e-mail  

SPPDemo on Tiwi-uB2 EM with TI MSP-EXP430F5438

If you open the code workspace in IAR, there is a BT_Stack_Lib group underneath the project. In there there are usually two files:

libTI_init_script_BT_CC2560.r43 and libTI_init_script_BT_CC256x.r43. Make sure the cc256x lib is selected.

Edited (July 1, 2013 17:53:33)

Offline

#6 July 2, 2013 08:10:32

Support
Registered:
Posts: 0
Profile   Send e-mail  

SPPDemo on Tiwi-uB2 EM with TI MSP-EXP430F5438

Hi please see the attached photo. It 's list of the SPPDemo workspace. I don 't see the files you mentioned above.

Evansrc=/Portals/0/Forums/Attachments/SPPDemo

Edited (July 2, 2013 08:10:32)

Offline

#7 Sept. 25, 2013 07:08:19

Support
Registered:
Posts: 0
Profile   Send e-mail  

SPPDemo on Tiwi-uB2 EM with TI MSP-EXP430F5438

Hello

I don 't found libTI_init_script_BT_CC256x.r43 dans l 'IAR.

Thank

Edited (Sept. 25, 2013 07:13:12)

Offline

#8 Sept. 25, 2013 08:08:38

pscharpf
Registered: 2015-06-29
Posts: 26
Profile   Send e-mail  

SPPDemo on Tiwi-uB2 EM with TI MSP-EXP430F5438

Make sure you have RF3 Jumpers in place. See Attachment.

Edited (Sept. 25, 2013 08:08:38)

Offline

#9 Sept. 25, 2013 09:22:58

Support
Registered:
Posts: 0
Profile   Send e-mail  

SPPDemo on Tiwi-uB2 EM with TI MSP-EXP430F5438

Thank, all is ok now

Edited (Sept. 25, 2013 09:24:13)

Offline

Board footer

Moderator control